Thread (2 messages) 2 messages, 2 authors, 2022-01-21

Re: [PATCH 26/31] net: bluetooth: changing LED_* from enum led_brightness to actual value

flat view

From: Marcel Holtmann <marcel@holtmann.org>
Date: 2022-01-21 20:19:50
Also in: linux-bluetooth, lkml

Hi Luiz,
quoted hunk ↗ jump to hunk
The enum led_brightness, which contains the declaration of LED_OFF,
LED_ON, LED_HALF and LED_FULL is obsolete, as the led class now supports
max_brightness.
---
net/bluetooth/leds.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/net/bluetooth/leds.c b/net/bluetooth/leds.c
index f46847632ffa..7f7e3eed9407 100644
--- a/net/bluetooth/leds.c
+++ b/net/bluetooth/leds.c
@@ -22,7 +22,7 @@ void hci_leds_update_powered(struct hci_dev *hdev, bool enabled)
{
	if (hdev->power_led)
		led_trigger_event(hdev->power_led,
-				  enabled ? LED_FULL : LED_OFF);
+				  enabled ? 255 : 0);

	if (!enabled) {
		struct hci_dev *d;
@@ -37,7 +37,7 @@ void hci_leds_update_powered(struct hci_dev *hdev, bool enabled)
		read_unlock(&hci_dev_list_lock);
	}

-	led_trigger_event(bt_power_led_trigger, enabled ? LED_FULL : LED_OFF);
+	led_trigger_event(bt_power_led_trigger, enabled ? 255 : 0);
}

static int power_activate(struct led_classdev *led_cdev)
@@ -48,7 +48,7 @@ static int power_activate(struct led_classdev *led_cdev)
	htrig = to_hci_basic_led_trigger(led_cdev->trigger);
	powered = test_bit(HCI_UP, &htrig->hdev->flags);

-	led_trigger_event(led_cdev->trigger, powered ? LED_FULL : LED_OFF);
+	led_trigger_event(led_cdev->trigger, powered ? 255 : 0);
how is this leading to more readable code?

What is wrong with providing proper constants to use instead of funky numbers now. I
think that changing every user of LED_FULL etc. and replacing it with 255 is stupid.

Seriously, add a #define LED_FULL 255 and leave the users alone.

Regards

Marcel
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help