Re: [PATCH bpf-next] bpf: Use struct_size() helper
From: patchwork-bot+netdevbpf@kernel.org
Date: 2021-12-21 23:40:15
Also in:
bpf, lkml
From: patchwork-bot+netdevbpf@kernel.org
Date: 2021-12-21 23:40:15
Also in:
bpf, lkml
Hello: This patch was applied to bpf/bpf-next.git (master) by Andrii Nakryiko [off-list ref]: On Mon, 20 Dec 2021 19:30:48 +0800 you wrote:
In an effort to avoid open-coded arithmetic in the kernel, use the struct_size() helper instead of open-coded calculation. Link: https://github.com/KSPP/linux/issues/160 Signed-off-by: Xiu Jianfeng <xiujianfeng@huawei.com> --- kernel/bpf/local_storage.c | 3 +-- kernel/bpf/reuseport_array.c | 6 +----- 2 files changed, 2 insertions(+), 7 deletions(-)
Here is the summary with links:
- [bpf-next] bpf: Use struct_size() helper
https://git.kernel.org/bpf/bpf-next/c/0dd668d2080c
You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html