Thread (3 messages) flat view 3 messages, 2 authors, 2021-11-26
STALE1729d

[PATCH] devlink: use min() to make code cleaner

From: <hidden>
Date: 2021-11-25 07:15:42
Also in: lkml
Subsystem: networking [general], the rest · Maintainers: "David S. Miller", Eric Dumazet, Jakub Kicinski, Paolo Abeni, Linus Torvalds

From: Lv Ruyi <redacted>

Use the macro 'min()' defined in 'include/linux/minmax.h' to avoid
opencoding it.

Reported-by: Zeal Robot <redacted>
Signed-off-by: Lv Ruyi <redacted>
---
 net/core/devlink.c | 6 ++----
 1 file changed, 2 insertions(+), 4 deletions(-)
diff --git a/net/core/devlink.c b/net/core/devlink.c
index d144a62cbf73..6ffbbb02fb91 100644
--- a/net/core/devlink.c
+++ b/net/core/devlink.c
@@ -9,6 +9,7 @@
 
 #include <linux/kernel.h>
 #include <linux/module.h>
+#include <linux/minmax.h>
 #include <linux/types.h>
 #include <linux/slab.h>
 #include <linux/gfp.h>
@@ -5763,10 +5764,7 @@ static int devlink_nl_region_read_snapshot_fill(struct sk_buff *skb,
 		u32 data_size;
 		u8 *data;
 
-		if (end_offset - curr_offset < DEVLINK_REGION_READ_CHUNK_SIZE)
-			data_size = end_offset - curr_offset;
-		else
-			data_size = DEVLINK_REGION_READ_CHUNK_SIZE;
+		data_size = min(end_offset - curr_offset, DEVLINK_REGION_READ_CHUNK_SIZE);
 
 		data = &snapshot->data[curr_offset];
 		err = devlink_nl_cmd_region_read_chunk_fill(skb, devlink,
-- 
2.25.1
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help