Re: [net-next PATCH v3 0/9] Multiple cleanup and feature for qca8k
flat view
From: patchwork-bot+netdevbpf@kernel.org
Date: 2021-11-22 15:50:12
Also in:
lkml
Hello: This series was applied to netdev/net-next.git (master) by David S. Miller [off-list ref]: On Mon, 22 Nov 2021 16:23:39 +0100 you wrote:
This is a reduced version of the old massive series. Refer to the changelog to know what is removed from this. We clean and convert the driver to GENMASK FIELD_PREP to clean multiple use of various naming scheme. (example we have a mix of _MASK, _S _M, and various name) The idea is to ""simplify"" and remove some shift and data handling by using FIELD API. The patch contains various checkpatch warning and are ignored to not create more mess in the header file. (fixing the too long line warning would results in regs definition less readable) [...]
Here is the summary with links:
- [net-next,v3,1/9] net: dsa: qca8k: remove redundant check in parse_port_config
https://git.kernel.org/netdev/net-next/c/b9133f3ef5a2
- [net-next,v3,2/9] net: dsa: qca8k: convert to GENMASK/FIELD_PREP/FIELD_GET
https://git.kernel.org/netdev/net-next/c/90ae68bfc2ff
- [net-next,v3,3/9] net: dsa: qca8k: remove extra mutex_init in qca8k_setup
https://git.kernel.org/netdev/net-next/c/994c28b6f971
- [net-next,v3,4/9] net: dsa: qca8k: move regmap init in probe and set it mandatory
https://git.kernel.org/netdev/net-next/c/36b8af12f424
- [net-next,v3,5/9] net: dsa: qca8k: initial conversion to regmap helper
https://git.kernel.org/netdev/net-next/c/8b5f3f29a81a
- [net-next,v3,6/9] net: dsa: qca8k: add additional MIB counter and make it dynamic
https://git.kernel.org/netdev/net-next/c/c126f118b330
- [net-next,v3,7/9] net: dsa: qca8k: add support for port fast aging
https://git.kernel.org/netdev/net-next/c/4592538bfb0d
- [net-next,v3,8/9] net: dsa: qca8k: add set_ageing_time support
https://git.kernel.org/netdev/net-next/c/6a3bdc5209f4
- [net-next,v3,9/9] net: dsa: qca8k: add support for mdb_add/del
https://git.kernel.org/netdev/net-next/c/ba8f870dfa63
You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html