Thread (2 messages) flat view 2 messages, 2 authors, 2021-11-22

Re: [PATCH] qed: Use the bitmap API to simplify some functions

From: patchwork-bot+netdevbpf@kernel.org
Date: 2021-11-22 15:00:20
Also in: kernel-janitors, lkml

Hello:

This patch was applied to netdev/net-next.git (master)
by David S. Miller [off-list ref]:

On Sun, 21 Nov 2021 20:12:54 +0100 you wrote:
'cid_map' is a bitmap. So use 'bitmap_zalloc()' to simplify code,
improve the semantic and avoid some open-coded arithmetic in allocator
arguments.

Also change the corresponding 'kfree()' into 'bitmap_free()' to keep
consistency.

[...]
Here is the summary with links:
  - qed: Use the bitmap API to simplify some functions
    https://git.kernel.org/netdev/net-next/c/5e6c7ccd3ea4

You are awesome, thank you!
-- 
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help