Hello:
This patch was applied to netdev/net-next.git (master)
by David S. Miller [off-list ref]:
On Thu, 18 Nov 2021 10:41:42 -0800 you wrote:
In preparation for FORTIFY_SOURCE performing compile-time and run-time
field bounds checking for memcpy(), memmove(), and memset(), avoid
intentionally writing across neighboring fields.
Use struct_group() in struct rss_hdr around members imm_data and intr_gen,
so they can be referenced together. This will allow memcpy() and sizeof()
to more easily reason about sizes, improve readability, and avoid future
warnings about writing beyond the end of imm_data.
[...]
Here is the summary with links:
- cxgb3: Use struct_group() for memcpy() region
https://git.kernel.org/netdev/net-next/c/88181f1d3474
You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html