Thread (7 messages) flat view 7 messages, 2 authors, 2021-11-19

Re: [PATCH] skbuff: Switch structure bounds to struct_group()

From: Jakub Kicinski <kuba@kernel.org>
Date: 2021-11-19 07:13:59
Also in: linux-hardening, lkml

On Thu, 18 Nov 2021 10:36:15 -0800 Kees Cook wrote:
In preparation for FORTIFY_SOURCE performing compile-time and run-time
field bounds checking for memcpy(), memmove(), and memset(), avoid
intentionally writing across neighboring fields.

Replace the existing empty member position markers "headers_start" and
"headers_end" with a struct_group(). This will allow memcpy() and sizeof()
to more easily reason about sizes, and improve readability.

"pahole" shows no size nor member offset changes to struct sk_buff.
"objdump -d" shows no object code changes (outside of WARNs affected by
source line number changes).
This adds ~27k of these warnings to W=1 gcc builds:

include/linux/skbuff.h:851:1: warning: directive in macro's argument list
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help