On Fri, 12 Nov 2021 17:57:08 +0000
Harshit Mogalapalli [off-list ref] wrote:
Hi Stephen,
Yes, you are correct.
To match the convention mapping should be like this instead:
State 3 ---> LOST_IN_BURST_PERIOD
State 4 ---> LOST_IN_GAP_PERIOD
Thanks,
Harshit
________________________________
From: Stephen Hemminger <stephen@networkplumber.org>
Sent: Friday, November 12, 2021 9:42 PM
To: Harshit Mogalapalli <redacted>
Cc: Jamal Hadi Salim <jhs@mojatatu.com>; Cong Wang <redacted>; Jiri Pirko <jiri@resnulli.us>; David S. Miller <davem@davemloft.net>; Jakub Kicinski <kuba@kernel.org>; netdev@vger.kernel.org <redacted>; linux-kernel@vger.kernel.org <redacted>; yangyingliang@huawei.com <redacted>
Subject: [External] : Re: [PATCH] net: sched: sch_netem: Refactor code in 4-state loss generator
On Thu, 11 Nov 2021 23:14:47 -0800
Harshit Mogalapalli [off-list ref] wrote:
quoted
Fixed comments to match description with variable names and
refactored code to match the convention as per [1].
[1] S. Salsano, F. Ludovici, A. Ordine, "Definition of a general
and intuitive loss model for packet networks and its implementation
in the Netem module in the Linux kernel"
Signed-off-by: Harshit Mogalapalli <redacted>
I wonder if this was changed accidently by this commit
Commit: a6e2fe17eba4 ("sch_netem: replace magic numbers with enumerate")
Could you resend with updated commit message and Fixes tag?