[PATCH] selftests/bpf: use swap() to make code cleaner
From: Yihao Han <hidden>
Date: 2021-11-12 03:27:27
Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid opencoding it. Signed-off-by: Yihao Han <redacted> --- tools/testing/selftests/bpf/progs/test_xdp_noinline.c | 5 +---- 1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/tools/testing/selftests/bpf/progs/test_xdp_noinline.c b/tools/testing/selftests/bpf/progs/test_xdp_noinline.c
index 596c4e71bf3a..6d9972168a7c 100644
--- a/tools/testing/selftests/bpf/progs/test_xdp_noinline.c
+++ b/tools/testing/selftests/bpf/progs/test_xdp_noinline.c@@ -428,7 +428,6 @@ int send_icmp_reply(void *data, void *data_end) { struct icmphdr *icmp_hdr; __u16 *next_iph_u16; - __u32 tmp_addr = 0; struct iphdr *iph; __u32 csum1 = 0; __u32 csum = 0;
@@ -444,9 +443,7 @@ int send_icmp_reply(void *data, void *data_end) icmp_hdr->type = 0; icmp_hdr->checksum += 0x0007; iph->ttl = 4; - tmp_addr = iph->daddr; - iph->daddr = iph->saddr; - iph->saddr = tmp_addr; + swap(iph->daddr, iph->saddr); iph->check = 0; next_iph_u16 = (__u16 *) iph; #pragma clang loop unroll(full)
--
2.17.1