Re: [PATCH] sfc: use swap() to make code cleaner
From: Martin Habets <hidden>
Date: 2021-11-08 11:05:40
Also in:
lkml
On Thu, Nov 04, 2021 at 02:53:50PM +0800, davidcomponentone@gmail.com wrote:
quoted hunk ↗ jump to hunk
From: Yang Guang <redacted> Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid opencoding it. Reported-by: Zeal Robot <redacted> Signed-off-by: Yang Guang <redacted> --- drivers/net/ethernet/sfc/falcon/efx.c | 8 ++------ 1 file changed, 2 insertions(+), 6 deletions(-)diff --git a/drivers/net/ethernet/sfc/falcon/efx.c b/drivers/net/ethernet/sfc/falcon/efx.c index c68837a951f4..314c9c69eb0e 100644 --- a/drivers/net/ethernet/sfc/falcon/efx.c +++ b/drivers/net/ethernet/sfc/falcon/efx.c@@ -817,9 +817,7 @@ ef4_realloc_channels(struct ef4_nic *efx, u32 rxq_entries, u32 txq_entries) efx->rxq_entries = rxq_entries; efx->txq_entries = txq_entries; for (i = 0; i < efx->n_channels; i++) { - channel = efx->channel[i]; - efx->channel[i] = other_channel[i]; - other_channel[i] = channel; + swap(efx->channel[i], other_channel[i]); }
The braces are no longer needed. Remove those. Martin
quoted hunk ↗ jump to hunk
/* Restart buffer table allocation */@@ -863,9 +861,7 @@ ef4_realloc_channels(struct ef4_nic *efx, u32 rxq_entries, u32 txq_entries) efx->rxq_entries = old_rxq_entries; efx->txq_entries = old_txq_entries; for (i = 0; i < efx->n_channels; i++) { - channel = efx->channel[i]; - efx->channel[i] = other_channel[i]; - other_channel[i] = channel; + swap(efx->channel[i], other_channel[i]); } goto out; }-- 2.30.2