Re: [RFC PATCH net-next 0/6] Rework DSA bridge TX forwarding offload API
From: Vladimir Oltean <vladimir.oltean@nxp.com>
Date: 2021-11-02 10:07:07
On Tue, Oct 26, 2021 at 07:26:19PM +0300, Vladimir Oltean wrote:
This change set replaces struct net_device *dp->bridge_dev with a struct dsa_bridge *dp->bridge that contains some extra information about that bridge, like a unique number kept by DSA. Up until now we computed that number only with the bridge TX forwarding offload feature, but it will be needed for other features too, like for isolation of FDB entries belonging to different bridges. Hardware implementations vary, but one common pattern seems to be the presence of a FID field which can be associated with that bridge number kept by DSA. The idea was outlined here: https://patchwork.kernel.org/project/netdevbpf/patch/20210818120150.892647-16-vladimir.oltean@nxp.com/ (the difference being that with this new proposal, drivers would not need to call dsa_bridge_num_find, instead the bridge_num would be part of the struct dsa_bridge :: num passed as argument). No functional change intended. Vladimir Oltean (6): net: dsa: make dp->bridge_num one-based net: dsa: assign a bridge number even without TX forwarding offload net: dsa: hide dp->bridge_dev and dp->bridge_num behind helpers net: dsa: rename dsa_port_offloads_bridge to dsa_port_offloads_bridge_dev net: dsa: keep the bridge_dev and bridge_num as part of the same structure net: dsa: eliminate dsa_switch_ops :: port_bridge_tx_fwd_{,un}offload drivers/net/dsa/b53/b53_common.c | 9 +- drivers/net/dsa/b53/b53_priv.h | 5 +- drivers/net/dsa/dsa_loop.c | 9 +- drivers/net/dsa/hirschmann/hellcreek.c | 5 +- drivers/net/dsa/lan9303-core.c | 7 +- drivers/net/dsa/lantiq_gswip.c | 25 +++-- drivers/net/dsa/microchip/ksz_common.c | 5 +- drivers/net/dsa/microchip/ksz_common.h | 4 +- drivers/net/dsa/mt7530.c | 18 +-- drivers/net/dsa/mv88e6xxx/chip.c | 145 ++++++++++++------------- drivers/net/dsa/ocelot/felix.c | 8 +- drivers/net/dsa/qca8k.c | 13 ++- drivers/net/dsa/rtl8366rb.c | 9 +- drivers/net/dsa/sja1105/sja1105_main.c | 40 +++++-- drivers/net/dsa/xrs700x/xrs700x.c | 10 +- include/linux/dsa/8021q.h | 9 +- include/net/dsa.h | 102 +++++++++++++---- net/dsa/dsa2.c | 57 ++++++---- net/dsa/dsa_priv.h | 59 ++-------- net/dsa/port.c | 123 +++++++++++---------- net/dsa/slave.c | 34 +++--- net/dsa/switch.c | 20 ++-- net/dsa/tag_8021q.c | 20 ++-- net/dsa/tag_dsa.c | 5 +- net/dsa/tag_ocelot.c | 2 +- net/dsa/tag_sja1105.c | 11 +- 26 files changed, 414 insertions(+), 340 deletions(-) -- 2.25.1
Any feedback?