Hello:
This series was applied to netdev/net-next.git (master)
by Pablo Neira Ayuso [off-list ref]:
On Mon, 1 Nov 2021 09:39:36 +0100 you wrote:
From: "Gustavo A. R. Silva" <gustavoars@kernel.org>
Use array_size() helper instead of the open-coded version in
copy_{from,to}_user(). These sorts of multiplication factors
need to be wrapped in array_size().
Link: https://github.com/KSPP/linux/issues/160
Signed-off-by: Gustavo A. R. Silva <gustavoars@kernel.org>
Reviewed-by: Kees Cook <redacted>
Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
[...]
Here is the summary with links:
- [net-next,1/5] netfilter: ebtables: use array_size() helper in copy_{from,to}_user()
https://git.kernel.org/netdev/net-next/c/241eb3f3ee42
- [net-next,2/5] netfilter: conntrack: set on IPS_ASSURED if flows enters internal stream state
https://git.kernel.org/netdev/net-next/c/b7b1d02fc439
- [net-next,3/5] netfilter: nft_meta: add NFT_META_IFTYPE
https://git.kernel.org/netdev/net-next/c/56fa95014a04
- [net-next,4/5] netfilter: nf_tables: convert pktinfo->tprot_set to flags field
https://git.kernel.org/netdev/net-next/c/b5bdc6f9c24d
- [net-next,5/5] netfilter: nft_payload: support for inner header matching / mangling
https://git.kernel.org/netdev/net-next/c/c46b38dc8743
You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html