Fillup ravb_alloc_rx_desc_gbeth() function to support RZ/G2L.
This patch also renames ravb_alloc_rx_desc to ravb_alloc_rx_desc_rcar
to be consistent with the naming convention used in sh_eth driver.
Signed-off-by: Biju Das <biju.das.jz@bp.renesas.com>
Reviewed-by: Lad Prabhakar <prabhakar.mahadev-lad.rj@bp.renesas.com>
---
RFC->v1:
* renamed "rgeth" to "gbeth".
* renamed ravb_alloc_rx_desc to ravb_alloc_rx_desc_rcar
---
drivers/net/ethernet/renesas/ravb_main.c | 17 ++++++++++++-----
1 file changed, 12 insertions(+), 5 deletions(-)
diff --git a/drivers/net/ethernet/renesas/ravb_main.c b/drivers/net/ethernet/renesas/ravb_main.c
index d4642783afc9..899a7f29046b 100644
--- a/drivers/net/ethernet/renesas/ravb_main.c
+++ b/drivers/net/ethernet/renesas/ravb_main.c
@@ -430,11 +430,18 @@ static void ravb_ring_format(struct net_device *ndev, int q)
static void *ravb_alloc_rx_desc_gbeth(struct net_device *ndev, int q)
{
- /* Place holder */
- return NULL;
+ struct ravb_private *priv = netdev_priv(ndev);
+ unsigned int ring_size;
+
+ ring_size = sizeof(struct ravb_rx_desc) * (priv->num_rx_ring[q] + 1);
+
+ priv->gbeth_rx_ring[q] = dma_alloc_coherent(ndev->dev.parent, ring_size,
+ &priv->rx_desc_dma[q],
+ GFP_KERNEL);
+ return priv->gbeth_rx_ring[q];
}
-static void *ravb_alloc_rx_desc(struct net_device *ndev, int q)
+static void *ravb_alloc_rx_desc_rcar(struct net_device *ndev, int q)
{
struct ravb_private *priv = netdev_priv(ndev);
unsigned int ring_size;@@ -2229,7 +2236,7 @@ static int ravb_mdio_release(struct ravb_private *priv)
static const struct ravb_hw_info ravb_gen3_hw_info = {
.rx_ring_free = ravb_rx_ring_free_rcar,
.rx_ring_format = ravb_rx_ring_format_rcar,
- .alloc_rx_desc = ravb_alloc_rx_desc,
+ .alloc_rx_desc = ravb_alloc_rx_desc_rcar,
.receive = ravb_rcar_rx,
.set_rate = ravb_set_rate_rcar,
.set_feature = ravb_set_features_rcar,@@ -2254,7 +2261,7 @@ static const struct ravb_hw_info ravb_gen3_hw_info = {
static const struct ravb_hw_info ravb_gen2_hw_info = {
.rx_ring_free = ravb_rx_ring_free_rcar,
.rx_ring_format = ravb_rx_ring_format_rcar,
- .alloc_rx_desc = ravb_alloc_rx_desc,
+ .alloc_rx_desc = ravb_alloc_rx_desc_rcar,
.receive = ravb_rcar_rx,
.set_rate = ravb_set_rate_rcar,
.set_feature = ravb_set_features_rcar,--
2.17.1