Thread (2 messages) flat view 2 messages, 2 authors, 2021-10-12

Re: [PATCH] af_unix: Rename UNIX-DGRAM to UNIX to maintain backwards compatability

From: patchwork-bot+netdevbpf@kernel.org
Date: 2021-10-12 10:20:09
Also in: lkml

Hello:

This patch was applied to netdev/net.git (master)
by David S. Miller [off-list ref]:

On Fri,  8 Oct 2021 14:59:45 -0700 you wrote:
Then name of this protocol changed in commit 94531cfcbe79 ("af_unix: Add
unix_stream_proto for sockmap") because that commit added stream support
to the af_unix protocol. Renaming the existing protocol makes a ChromeOS
protocol test[1] fail now that the name has changed in
/proc/net/protocols from "UNIX" to "UNIX-DGRAM".

Let's put the name back to how it was while keeping the stream protocol
as "UNIX-STREAM" so that the procfs interface doesn't change. This fixes
the test and maintains backwards compatibility in proc.

[...]
Here is the summary with links:
  - af_unix: Rename UNIX-DGRAM to UNIX to maintain backwards compatability
    https://git.kernel.org/netdev/net/c/0edf0824e0dc

You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help