Thread (21 messages) 21 messages, 2 authors, 2021-10-05

Re: [PATCH rdma-next v2 08/13] RDMA/nldev: Allow optional-counter status configuration through RDMA netlink

flat view

From: Jason Gunthorpe <jgg@nvidia.com>
Date: 2021-10-04 18:03:17
Also in: linux-rdma, lkml

On Thu, Sep 30, 2021 at 11:02:24AM +0300, Leon Romanovsky wrote:
quoted hunk ↗ jump to hunk
-	if (nla_get_u32(tb[RDMA_NLDEV_ATTR_STAT_RES]) != RDMA_NLDEV_ATTR_RES_QP)
-		return -EINVAL;
+	target = kcalloc(BITS_TO_LONGS(stats->num_counters),
+		       sizeof(long), GFP_KERNEL);
+	if (!target)
+		return -ENOMEM;
Same comment about the type here

This almost wants to be two patches to split up the set_doit then add
the new setter, it is hard to read..

Jason
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help