[PATCH net-next 0/6] ethernet: add eth_hw_addr_gen() for switches
From: Jakub Kicinski <kuba@kernel.org>
Date: 2021-10-18 21:10:24
While doing the last polishing of the drivers/ethernet changes I realized we have a handful of drivers offsetting some base MAC addr by an id. So I decided to add a helper for it. The helper takes care of wrapping which is probably not 100% necessary but seems like a good idea. And it saves driver side LoC (the diffstat is actually negative if we compare against the changes I'd have to make if I was to convert all these drivers to not operate directly on netdev->dev_addr). Jakub Kicinski (6): ethernet: add a helper for assigning port addresses ethernet: ocelot: use eth_hw_addr_gen() ethernet: prestera: use eth_hw_addr_gen() ethernet: fec: use eth_hw_addr_gen() ethernet: mlxsw: use eth_hw_addr_gen() ethernet: sparx5: use eth_hw_addr_gen() drivers/net/ethernet/freescale/fec_main.c | 5 +---- .../ethernet/marvell/prestera/prestera_main.c | 7 +++++-- drivers/net/ethernet/mellanox/mlxsw/minimal.c | 10 +++------ .../net/ethernet/mellanox/mlxsw/spectrum.c | 8 +++---- .../ethernet/microchip/sparx5/sparx5_netdev.c | 4 +--- drivers/net/ethernet/mscc/ocelot_net.c | 3 +-- include/linux/etherdevice.h | 21 +++++++++++++++++++ 7 files changed, 36 insertions(+), 22 deletions(-) -- 2.31.1