Re: [PATCH bpf-next v3 06/10] bpf: Bump MAX_BPF_STACK size to 768 bytes
From: Alexei Starovoitov <hidden>
Date: 2021-09-16 02:56:36
Also in:
bpf
On Wed, Sep 15, 2021 at 10:57 AM Kumar Kartikeya Dwivedi [off-list ref] wrote:
On Wed, Sep 15, 2021 at 10:03:53PM IST, Alexei Starovoitov wrote:quoted
On Wed, Sep 15, 2021 at 10:39:39AM +0530, Kumar Kartikeya Dwivedi wrote:quoted
Increase the maximum stack size accessible to BPF program to 768 bytes. This is done so that gen_loader can use 94 additional fds for kfunc BTFs that it passes in to fd_array from the remaining space available for the loader_stack struct to expand. Signed-off-by: Kumar Kartikeya Dwivedi <memxor@gmail.com> --- include/linux/filter.h | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)diff --git a/include/linux/filter.h b/include/linux/filter.h index 4a93c12543ee..b214189ece62 100644 --- a/include/linux/filter.h +++ b/include/linux/filter.h@@ -82,8 +82,8 @@ struct ctl_table_header; */ #define BPF_SYM_ELF_TYPE 't' -/* BPF program can access up to 512 bytes of stack space. */ -#define MAX_BPF_STACK 512 +/* BPF program can access up to 768 bytes of stack space. */ +#define MAX_BPF_STACK 768Yikes. I guess you meant as RFC, right? You didn't really propose to increase prog stack size just for that, right?Yes, and right, it's ugly :/.quoted
In the later patch: +/* MAX_BPF_STACK is 768 bytes, so (64 + 32 + 94 (MAX_KFUNC_DESCS) + 2) * 4 */ #define MAX_USED_MAPS 64 #define MAX_USED_PROGS 32@@ -31,6 +33,8 @@ struct loader_stack { __u32 btf_fd; __u32 map_fd[MAX_USED_MAPS]; __u32 prog_fd[MAX_USED_PROGS]; + /* Update insn->off store when reordering kfunc_btf_fd */ + __u32 kfunc_btf_fd[MAX_KFUNC_DESCS]; __u32 inner_map_fd;}; There are few other ways to do that. For example: A: rename map_fd[] into fds[] and store both map and btf FDs in there. B: move map and btf FDs into data instead of stack.Both are great suggestions, I thought about A but not B, but it will be better (even though it requires more changes, we can do full 256 BTF fds using B). Thanks!
btw fd_array doesn't have to have valid FDs in all slots when passed into the prog_load command. If bpf prog doesn't index into them they can have garbage. Just mentioning in case that simplifies the implementation. I suspect packing btf_fds right after map_fds with no gaps will not be hard to do, but in case it's somehow too painful there could be a gap.