Previously with CONFIG_QRTR=m a separate ns.ko would be built which
wasn't done on purpose and should be included in qrtr.ko.
Rename qrtr.c to af_qrtr.c so we can build a qrtr.ko with both af_qrtr.c
and ns.c.
Signed-off-by: Luca Weiss <redacted>
---
net/qrtr/Makefile | 3 ++-
net/qrtr/{qrtr.c => af_qrtr.c} | 0
2 files changed, 2 insertions(+), 1 deletion(-)
rename net/qrtr/{qrtr.c => af_qrtr.c} (100%)
Previously with CONFIG_QRTR=m a separate ns.ko would be built which
wasn't done on purpose and should be included in qrtr.ko.
Rename qrtr.c to af_qrtr.c so we can build a qrtr.ko with both af_qrtr.c
and ns.c.
Nice, I don't think we ever intended to end up with "ns.ko" on its own.
Reviewed-by: Bjorn Andersson <redacted>
Regards,
Bjorn
Previously with CONFIG_QRTR=m a separate ns.ko would be built which
wasn't done on purpose and should be included in qrtr.ko.
Rename qrtr.c to af_qrtr.c so we can build a qrtr.ko with both af_qrtr.c
and ns.c.
Signed-off-by: Luca Weiss <redacted>
---
net/qrtr/Makefile | 3 ++-
net/qrtr/{qrtr.c => af_qrtr.c} | 0
2 files changed, 2 insertions(+), 1 deletion(-)
rename net/qrtr/{qrtr.c => af_qrtr.c} (100%)
Hello:
This patch was applied to netdev/net-next.git (refs/heads/master):
On Tue, 28 Sep 2021 19:11:57 +0200 you wrote:
Previously with CONFIG_QRTR=m a separate ns.ko would be built which
wasn't done on purpose and should be included in qrtr.ko.
Rename qrtr.c to af_qrtr.c so we can build a qrtr.ko with both af_qrtr.c
and ns.c.
Signed-off-by: Luca Weiss <redacted>
[...]