Re: [PATCH ipsec v3 0/2] xfrm: fix uapi for the default policy
From: Nicolas Dichtel <hidden>
Date: 2021-09-15 09:55:59
Le 15/09/2021 à 11:19, Antony Antony a écrit :
Hi Nicolas, On Tue, Sep 14, 2021 at 16:46:32 +0200, Nicolas Dichtel wrote:quoted
This feature has just been merged after the last release, thus it's still time to fix the uapi. As stated in the thread, the uapi is based on some magic values (from the userland POV).I like your proposal to make uapi 3 different variables, instead of flags. This fix leave kernel internal representation as a flags in struct netns_xfrm u8 policy_default; I have a concern. If your patch is applied, the uapi and xfrm internal representations would be inconsistant. I think they should be the same in this case.
I agree.
It would easier to follow the code path. On the other hand we should apply this uapi change ASAP, in 5.15 release cycle, to avoid ABI change.
I also agree.
Could you also change xfrm policy_default to three variables?
Yes, I propose to send a follow up on ipsec-next once this series is applied. The internal representation could be changed later, I prefer to keep this change minimal for the ipsec tree. Thank you, Nicolas