[PATCH v2 0/3] kselftests: clean configs

STALE1805d

Revision v2 of 2 in this series.

4 messages, 3 authors, 2021-08-27 · open the first message on its own page

[PATCH v2 0/3] kselftests: clean configs

From: Li Zhijian <hidden>
Date: 2021-08-26 01:54:35

0Day will check if all configs listing under selftests are able to be enabled properly.

For the missing configs, it will report something like:
LKP WARN miss config CONFIG_SYNC= of sync/config

CC: kernel test robot <redacted>
CC: "Jason A. Donenfeld" <Jason@zx2c4.com>
CC: Nick Desaulniers <ndesaulniers@google.com>
CC: Masahiro Yamada <masahiroy@kernel.org>
CC: wireguard@lists.zx2c4.com
CC: netdev@vger.kernel.org

CC: "Rafael J. Wysocki" <redacted>
CC: Viresh Kumar <viresh.kumar@linaro.org>
CC: linux-pm@vger.kernel.org
Reported-by: kernel test robot <redacted>

Li Zhijian (3):
  selftests/sync: Remove the deprecated config SYNC
  selftests/cpufreq: Rename DEBUG_PI_LIST to DEBUG_PLIST
  selftests/wireguard: Rename DEBUG_PI_LIST to DEBUG_PLIST

 tools/testing/selftests/cpufreq/config              | 2 +-
 tools/testing/selftests/sync/config                 | 1 -
 tools/testing/selftests/wireguard/qemu/debug.config | 2 +-
 3 files changed, 2 insertions(+), 3 deletions(-)

-- 
2.31.1


[PATCH v2 3/3] selftests/wireguard: Rename DEBUG_PI_LIST to DEBUG_PLIST

From: Li Zhijian <hidden>
Date: 2021-08-26 01:54:51

DEBUG_PI_LIST was renamed to DEBUG_PLIST since 8e18faeac3 ("lib/plist: rename DEBUG_PI_LIST to DEBUG_PLIST")

CC: "Jason A. Donenfeld" <Jason@zx2c4.com>
CC: Nick Desaulniers <ndesaulniers@google.com>
CC: Masahiro Yamada <masahiroy@kernel.org>
CC: wireguard@lists.zx2c4.com
CC: netdev@vger.kernel.org

Signed-off-by: Li Zhijian <redacted>
---
 tools/testing/selftests/wireguard/qemu/debug.config | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tools/testing/selftests/wireguard/qemu/debug.config b/tools/testing/selftests/wireguard/qemu/debug.config
index fe07d97df9fa..2b321b8a96cf 100644
--- a/tools/testing/selftests/wireguard/qemu/debug.config
+++ b/tools/testing/selftests/wireguard/qemu/debug.config
@@ -47,7 +47,7 @@ CONFIG_DEBUG_ATOMIC_SLEEP=y
 CONFIG_TRACE_IRQFLAGS=y
 CONFIG_DEBUG_BUGVERBOSE=y
 CONFIG_DEBUG_LIST=y
-CONFIG_DEBUG_PI_LIST=y
+CONFIG_DEBUG_PLIST=y
 CONFIG_PROVE_RCU=y
 CONFIG_SPARSE_RCU_POINTER=y
 CONFIG_RCU_CPU_STALL_TIMEOUT=21
-- 
2.31.1


Re: [PATCH v2 3/3] selftests/wireguard: Rename DEBUG_PI_LIST to DEBUG_PLIST

From: Shuah Khan <skhan@linuxfoundation.org>
Date: 2021-08-26 21:11:36

On 8/25/21 7:58 PM, Li Zhijian wrote:
DEBUG_PI_LIST was renamed to DEBUG_PLIST since 8e18faeac3 ("lib/plist: rename DEBUG_PI_LIST to DEBUG_PLIST")

CC: "Jason A. Donenfeld" <Jason@zx2c4.com>
CC: Nick Desaulniers <ndesaulniers@google.com>
CC: Masahiro Yamada <masahiroy@kernel.org>
CC: wireguard@lists.zx2c4.com
CC: netdev@vger.kernel.org

Signed-off-by: Li Zhijian <redacted>
---
Can you please state what you are fixing and also keep the sentences
75 chars or less.

Where is LKP warning? Include the warning and explain why this
change is necessary.

thanks,
-- Shuah

Re: [PATCH v2 3/3] selftests/wireguard: Rename DEBUG_PI_LIST to DEBUG_PLIST

From: "Jason A. Donenfeld" <Jason@zx2c4.com>
Date: 2021-08-27 14:24:01

Hi,

On Thu, Aug 26, 2021 at 3:54 AM Li Zhijian [off-list ref] wrote:
DEBUG_PI_LIST was renamed to DEBUG_PLIST since 8e18faeac3 ("lib/plist: rename DEBUG_PI_LIST to DEBUG_PLIST")
Thanks for the patch. I've queued this up in my wireguard-linux.git
tree for some rounds of CI, and I'll send it back out in the next
series I send to netdev.

Regards,
Jason
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help