Thread (108 messages) 108 messages, 22 authors, 2021-11-24

Re: [PATCH v2 22/63] HID: cp2112: Use struct_group() for memcpy() region

From: Jiri Kosina <jikos@kernel.org>
Date: 2021-08-20 13:01:52
Also in: dri-devel, linux-block, linux-hardening, linux-input, linux-kbuild, linux-staging, linux-wireless, lkml

On Tue, 17 Aug 2021, Kees Cook wrote:
In preparation for FORTIFY_SOURCE performing compile-time and run-time
field bounds checking for memcpy(), memmove(), and memset(), avoid
intentionally writing across neighboring fields.

Use struct_group() in struct cp2112_string_report around members report,
length, type, and string, so they can be referenced together. This will
allow memcpy() and sizeof() to more easily reason about sizes, improve
readability, and avoid future warnings about writing beyond the end of
report.

"pahole" shows no size nor member offset changes to struct
cp2112_string_report.  "objdump -d" shows no meaningful object
code changes (i.e. only source line number induced differences.)

Cc: Jiri Kosina <jikos@kernel.org>
Cc: Benjamin Tissoires <redacted>
Cc: linux-input@vger.kernel.org
Signed-off-by: Kees Cook <redacted>
Applied, thanks.

-- 
Jiri Kosina
SUSE Labs
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help