Hello:
This patch was applied to netdev/net.git (refs/heads/master):
On Mon, 16 Aug 2021 14:13:33 +0300 you wrote:
The bounds check on "index" doesn't catch negative values. Using
ARRAY_SIZE() directly is more readable and more robust because it prevents
negative values for "index". Fortunately we only pass valid values to
ipc_chnl_cfg_get() so this patch does not affect runtime.
Reported-by: Solomon Ucko <redacted>
Signed-off-by: Dan Carpenter <redacted>
[...]
Here is the summary with links:
- [v2,net] net: iosm: Prevent underflow in ipc_chnl_cfg_get()
https://git.kernel.org/netdev/net/c/4f3f2e3fa043
You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html