On Fri, 13 Aug 2021 08:27:30 +0300 Alexey Dobriyan wrote:
On Thu, Aug 12, 2021 at 03:05:52PM -0700, Jakub Kicinski wrote:
quoted
On Fri, 13 Aug 2021 00:24:01 +0300 Alexey Dobriyan wrote:
quoted
Kernel permits pointer arithmetic on "void*" so might as well use it
without casts back and forth.
But why change existing code? It's perfectly fine, right?
It is harder to read (marginally of course).
TBH I prefer the current code, I don't have to wonder what type
nlmsg_data() returns and whether it's okay to do void* arithmetic
in this header (if it's uAPI). Sorry :(