Thread (1 message) 1 message, 1 author, 2021-07-31

Re: [PATCH 04/64] stddef: Introduce struct_group() helper macro

From: Kees Cook <hidden>
Date: 2021-07-31 15:10:27
Also in: dri-devel, linux-block, linux-cxl, linux-hardening, linux-kbuild, linux-staging, linux-wireless, lkml

On Sat, Jul 31, 2021 at 07:24:44AM +0200, Rasmus Villemoes wrote:
On Sat, Jul 31, 2021, 04:59 Kees Cook [off-list ref] wrote:
quoted
On Fri, Jul 30, 2021 at 10:19:20PM +0000, Williams, Dan J wrote:
quoted
On Wed, 2021-07-28 at 14:59 -0700, Kees Cook wrote:
quoted
 /**
  * struct_group(NAME, MEMBERS)
  *
@@ -67,7 +73,10 @@ enum {
  * @NAME: The name of the mirrored sub-struct
  * @MEMBERS: The member declarations for the mirrored structs
  */
-#define struct_group(NAME, MEMBERS)    \
+#define struct_group(NAME, MEMBERS...) \
        struct_group_attr(NAME, /* no attrs */, MEMBERS)

+#define struct_group_typed(TYPE, NAME, MEMBERS...) \
+       struct_group_attr_typed(TYPE, NAME, /* no attrs */, MEMBERS)
+
 #endif
Awesome! My instinct is to expose the resulting API as:

__struct_group(type, name, attrs, members...)

struct_group(name, members...)
struct_group_attr(name, attrs, members...)
struct_group_typed(type, name, members...)
Bikeshed: can we use proper nomenclature please. s/type/tag/,
s/typed/tagged.
Ah! Thank you. I went looking for the spec on what these are called and
couldn't find it. "struct $tag" is the type, then, yes? So IIUC now:

       |    type   | members  | name
       |       tag
	struct foo { int bar; } baz;

-- 
Kees Cook
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help