Dear David,
I'm happy to hear you again.
On 7/9/21 8:58 PM, David Miller wrote:
Please do not use inline in foo.c files, let the compiler decde.
Thank you for the hint, I did not know it, and will follow him next time.
This time I'm going to move this helper somewhere anyway:
either to net/core/skbuff.c as exported function where it will lost inline anyway,
or to include/linux/skbuff.h where inline is (it seems?) acceptable.
Could you please help me to find better name for this helper?
I would like to change its current name: 'skb_expand_head' looks very similar
to widely used 'pskb_expand_head' but have different semantic.
I afraid they can be accidentally misused in future.
Thank you,
Vasily Averin.