This patchset is intended to remove duplicated code around MTU calculation
and consolidate in one function. Also it alignes IPv4 and IPv6 code in
functions naming and usage
Vadim Fedorenko (2):
net: ipv6: introduce ip6_dst_mtu_maybe_forward
net: ipv4: Consolidate ipv4_mtu and ip_dst_mtu_maybe_forward
include/net/ip.h | 22 ++++++++++++++++++----
include/net/ip6_route.h | 5 +++--
net/ipv4/route.c | 21 +--------------------
net/ipv6/ip6_output.c | 2 +-
net/ipv6/route.c | 20 +-------------------
net/netfilter/nf_flow_table_core.c | 2 +-
6 files changed, 25 insertions(+), 47 deletions(-)
--
2.18.4