Re: [PATCH] net: hisilicon: rename CACHE_LINE_MASK to avoid redefinition
From: patchwork-bot+netdevbpf@kernel.org
Date: 2021-07-19 17:11:20
Hello: This patch was applied to netdev/net.git (refs/heads/master): On Sun, 18 Jul 2021 13:38:34 -0700 you wrote:
Building on ARCH=arc causes a "redefined" warning, so rename this
driver's CACHE_LINE_MASK to avoid the warning.
../drivers/net/ethernet/hisilicon/hip04_eth.c:134: warning: "CACHE_LINE_MASK" redefined
134 | #define CACHE_LINE_MASK 0x3F
In file included from ../include/linux/cache.h:6,
from ../include/linux/printk.h:9,
from ../include/linux/kernel.h:19,
from ../include/linux/list.h:9,
from ../include/linux/module.h:12,
from ../drivers/net/ethernet/hisilicon/hip04_eth.c:7:
../arch/arc/include/asm/cache.h:17: note: this is the location of the previous definition
17 | #define CACHE_LINE_MASK (~(L1_CACHE_BYTES - 1))
[...]
Here is the summary with links:
- net: hisilicon: rename CACHE_LINE_MASK to avoid redefinition
https://git.kernel.org/netdev/net/c/b16f3299ae1a
You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html