Re: [PATCH net-next] drivers: net: netdevsim: fix devlink_trap selftests failing
From: Ido Schimmel <hidden>
Date: 2021-06-17 06:39:51
Also in:
lkml
On Wed, Jun 16, 2021 at 09:34:05PM +0300, Oleksandr Mazur wrote: You need to add a proper commit message here
Fixes: a7b3527a43fe ("drivers: net: netdevsim: add devlink trap_drop_counter_get implementation")No blank line between Fixes and SoB
Signed-off-by: Oleksandr Mazur <redacted> --- Test-results: selftests: drivers/net/netdevsim: devlink_trap.sh TEST: Initialization [ OK ] TEST: Trap action [ OK ] TEST: Trap metadata [ OK ] TEST: Non-existing trap [ OK ] TEST: Non-existing trap action [ OK ] TEST: Trap statistics [ OK ] TEST: Trap group action [ OK ] TEST: Non-existing trap group [ OK ] TEST: Trap group statistics [ OK ] TEST: Trap policer [ OK ] TEST: Trap policer binding [ OK ] TEST: Port delete [ OK ] TEST: Device delete [ OK ]
This can be in the commit message
quoted hunk ↗ jump to hunk
--- drivers/net/netdevsim/dev.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)diff --git a/drivers/net/netdevsim/dev.c b/drivers/net/netdevsim/dev.c index d85521989753..aad5e3d4a2b6 100644 --- a/drivers/net/netdevsim/dev.c +++ b/drivers/net/netdevsim/dev.c@@ -269,7 +269,7 @@ static int nsim_dev_debugfs_init(struct nsim_dev *nsim_dev) err = PTR_ERR(nsim_dev->nodes_ddir); goto err_out; } - debugfs_create_bool("fail_trap_counter_get", 0600, + debugfs_create_bool("fail_trap_drop_counter_get", 0600, nsim_dev->ddir, &nsim_dev->fail_trap_counter_get);
Please change the name of the variable to match the name of the corresponding debugfs file
nsim_udp_tunnels_debugfs_create(nsim_dev); -- 2.17.1