[PATCH net-next] sfc: falcon: use DEVICE_ATTR_*() macro

Subsystems: networking drivers, sfc network driver, the rest

STALE1901d

2 messages, 2 authors, 2021-05-24 · open the first message on its own page

[PATCH net-next] sfc: falcon: use DEVICE_ATTR_*() macro

From: YueHaibing <hidden>
Date: 2021-05-23 03:24:57

Use DEVICE_ATTR_*() helper instead of plain DEVICE_ATTR,
which makes the code a bit shorter and easier to read.

Signed-off-by: YueHaibing <redacted>
---
 drivers/net/ethernet/sfc/falcon/efx.c           |  4 ++--
 drivers/net/ethernet/sfc/falcon/falcon_boards.c | 10 +++++-----
 2 files changed, 7 insertions(+), 7 deletions(-)
diff --git a/drivers/net/ethernet/sfc/falcon/efx.c b/drivers/net/ethernet/sfc/falcon/efx.c
index 5e7a57b680ca..9ec752a43c75 100644
--- a/drivers/net/ethernet/sfc/falcon/efx.c
+++ b/drivers/net/ethernet/sfc/falcon/efx.c
@@ -2254,12 +2254,12 @@ static struct notifier_block ef4_netdev_notifier = {
 };
 
 static ssize_t
-show_phy_type(struct device *dev, struct device_attribute *attr, char *buf)
+phy_type_show(struct device *dev, struct device_attribute *attr, char *buf)
 {
 	struct ef4_nic *efx = dev_get_drvdata(dev);
 	return sprintf(buf, "%d\n", efx->phy_type);
 }
-static DEVICE_ATTR(phy_type, 0444, show_phy_type, NULL);
+static DEVICE_ATTR_RO(phy_type);
 
 static int ef4_register_netdev(struct ef4_nic *efx)
 {
diff --git a/drivers/net/ethernet/sfc/falcon/falcon_boards.c b/drivers/net/ethernet/sfc/falcon/falcon_boards.c
index 729a05c1b0cf..2d2d8099011e 100644
--- a/drivers/net/ethernet/sfc/falcon/falcon_boards.c
+++ b/drivers/net/ethernet/sfc/falcon/falcon_boards.c
@@ -354,16 +354,16 @@ static int sfe4001_poweron(struct ef4_nic *efx)
 	return rc;
 }
 
-static ssize_t show_phy_flash_cfg(struct device *dev,
+static ssize_t phy_flash_cfg_show(struct device *dev,
 				  struct device_attribute *attr, char *buf)
 {
 	struct ef4_nic *efx = dev_get_drvdata(dev);
 	return sprintf(buf, "%d\n", !!(efx->phy_mode & PHY_MODE_SPECIAL));
 }
 
-static ssize_t set_phy_flash_cfg(struct device *dev,
-				 struct device_attribute *attr,
-				 const char *buf, size_t count)
+static ssize_t phy_flash_cfg_store(struct device *dev,
+				   struct device_attribute *attr,
+				   const char *buf, size_t count)
 {
 	struct ef4_nic *efx = dev_get_drvdata(dev);
 	enum ef4_phy_mode old_mode, new_mode;
@@ -396,7 +396,7 @@ static ssize_t set_phy_flash_cfg(struct device *dev,
 	return err ? err : count;
 }
 
-static DEVICE_ATTR(phy_flash_cfg, 0644, show_phy_flash_cfg, set_phy_flash_cfg);
+static DEVICE_ATTR_RW(phy_flash_cfg);
 
 static void sfe4001_fini(struct ef4_nic *efx)
 {
-- 
2.17.1

Re: [PATCH net-next] sfc: falcon: use DEVICE_ATTR_*() macro

From: patchwork-bot+netdevbpf@kernel.org
Date: 2021-05-24 00:30:24

Hello:

This patch was applied to netdev/net-next.git (refs/heads/master):

On Sun, 23 May 2021 11:24:09 +0800 you wrote:
Use DEVICE_ATTR_*() helper instead of plain DEVICE_ATTR,
which makes the code a bit shorter and easier to read.

Signed-off-by: YueHaibing <redacted>
---
 drivers/net/ethernet/sfc/falcon/efx.c           |  4 ++--
 drivers/net/ethernet/sfc/falcon/falcon_boards.c | 10 +++++-----
 2 files changed, 7 insertions(+), 7 deletions(-)
Here is the summary with links:
  - [net-next] sfc: falcon: use DEVICE_ATTR_*() macro
    https://git.kernel.org/netdev/net-next/c/4934fb7dc409

You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help