[PATCH net-next] net/9p: use DEVICE_ATTR_RO macro

Subsystems: 9p file system, the rest

STALE1907d

2 messages, 2 authors, 2021-05-19 · open the first message on its own page

[PATCH net-next] net/9p: use DEVICE_ATTR_RO macro

From: YueHaibing <hidden>
Date: 2021-05-19 03:00:13

Use DEVICE_ATTR_RO helper instead of plain DEVICE_ATTR,
which makes the code a bit shorter and easier to read.

Signed-off-by: YueHaibing <redacted>
---
 net/9p/trans_virtio.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/net/9p/trans_virtio.c b/net/9p/trans_virtio.c
index 93f2f8654882..43339f314a86 100644
--- a/net/9p/trans_virtio.c
+++ b/net/9p/trans_virtio.c
@@ -528,8 +528,8 @@ p9_virtio_zc_request(struct p9_client *client, struct p9_req_t *req,
 	return err;
 }
 
-static ssize_t p9_mount_tag_show(struct device *dev,
-				struct device_attribute *attr, char *buf)
+static ssize_t mount_tag_show(struct device *dev,
+			      struct device_attribute *attr, char *buf)
 {
 	struct virtio_chan *chan;
 	struct virtio_device *vdev;
@@ -544,7 +544,7 @@ static ssize_t p9_mount_tag_show(struct device *dev,
 	return tag_len + 1;
 }
 
-static DEVICE_ATTR(mount_tag, 0444, p9_mount_tag_show, NULL);
+static DEVICE_ATTR_RO(mount_tag);
 
 /**
  * p9_virtio_probe - probe for existence of 9P virtio channels
-- 
2.17.1

Re: [PATCH net-next] net/9p: use DEVICE_ATTR_RO macro

From: asmadeus@codewreck.org
Date: 2021-05-19 03:27:44

YueHaibing wrote on Wed, May 19, 2021 at 10:56:39AM +0800:
Use DEVICE_ATTR_RO helper instead of plain DEVICE_ATTR,
which makes the code a bit shorter and easier to read.

Signed-off-by: YueHaibing <redacted>
Sure, why not.
Will queue to -next tomorrow-ish

-- 
Dominique
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help