Re: [RFC PATCH 1/2] regmap: add miim bus support
From: Andrew Lunn <andrew@lunn.ch>
Date: 2021-04-09 19:44:20
Also in:
linux-devicetree, linux-gpio
From: Andrew Lunn <andrew@lunn.ch>
Date: 2021-04-09 19:44:20
Also in:
linux-devicetree, linux-gpio
On Fri, Apr 09, 2021 at 07:16:42PM +0100, Mark Brown wrote:
On Fri, Apr 09, 2021 at 08:14:22PM +0200, Sander Vanheule wrote:quoted
The kernel has the mii_bus struct to describe the bus master, but like you noted the bus is generaly refered to as an MDIO interface. I'm fine with naming it MDIO to make it easier to spot.Either mii_bus or mdio seem like an improvement - something matching existing kernel terminology, I guess mdio is consistent with the API it works with so...
I would also suggest mdio. The mii_bus code is an old framework which
does not see any work done to it.
Andrew