Re: [PATCH bpf v2 2/2] bpf/selftests: test that kernel rejects a TCP CC with an invalid license
From: Toke Høiland-Jørgensen <hidden>
Date: 2021-03-26 09:44:19
Also in:
bpf
Andrii Nakryiko [off-list ref] writes:
On Thu, Mar 25, 2021 at 2:11 PM Toke Høiland-Jørgensen [off-list ref] wrote:quoted
This adds a selftest to check that the verifier rejects a TCP CC struct_ops with a non-GPL license. v2: - Use a minimal struct_ops BPF program instead of rewriting bpf_dctcp's license in memory. - Check for the verifier reject message instead of just the return code. Signed-off-by: Toke Høiland-Jørgensen <redacted> --- .../selftests/bpf/prog_tests/bpf_tcp_ca.c | 44 +++++++++++++++++++ .../selftests/bpf/progs/bpf_nogpltcp.c | 19 ++++++++ 2 files changed, 63 insertions(+) create mode 100644 tools/testing/selftests/bpf/progs/bpf_nogpltcp.cdiff --git a/tools/testing/selftests/bpf/prog_tests/bpf_tcp_ca.c b/tools/testing/selftests/bpf/prog_tests/bpf_tcp_ca.c index 37c5494a0381..a09c716528e1 100644 --- a/tools/testing/selftests/bpf/prog_tests/bpf_tcp_ca.c +++ b/tools/testing/selftests/bpf/prog_tests/bpf_tcp_ca.c@@ -6,6 +6,7 @@ #include <test_progs.h> #include "bpf_dctcp.skel.h" #include "bpf_cubic.skel.h" +#include "bpf_nogpltcp.skel.h"total nit, but my eyes can't read "nogpltcp"... wouldn't "bpf_tcp_nogpl" be a bit easier?
Haha, yeah, good point - my eyes also just lump it into a blob...
quoted
#define min(a, b) ((a) < (b) ? (a) : (b))@@ -227,10 +228,53 @@ static void test_dctcp(void) bpf_dctcp__destroy(dctcp_skel); } +static char *err_str = NULL; +static bool found = false; + +static int libbpf_debug_print(enum libbpf_print_level level, + const char *format, va_list args) +{ + char *log_buf; + + if (level != LIBBPF_WARN || + strcmp(format, "libbpf: \n%s\n")) { + vprintf(format, args); + return 0; + } + + log_buf = va_arg(args, char *); + if (!log_buf) + goto out; + if (err_str && strstr(log_buf, err_str) != NULL) + found = true; +out: + printf(format, log_buf); + return 0; +} + +static void test_invalid_license(void) +{ + libbpf_print_fn_t old_print_fn = NULL; + struct bpf_nogpltcp *skel; + + err_str = "struct ops programs must have a GPL compatible license"; + old_print_fn = libbpf_set_print(libbpf_debug_print); + + skel = bpf_nogpltcp__open_and_load(); + if (CHECK(skel, "bpf_nogplgtcp__open_and_load()", "didn't fail\n"))ASSERT_OK_PTR()quoted
+ bpf_nogpltcp__destroy(skel);you should destroy unconditionallyquoted
+ + CHECK(!found, "errmsg check", "expected string '%s'", err_str);ASSERT_EQ(found, true, "expected_err_msg"); I can never be sure which way CHECK() is checking
Ah, thanks! I always get confused about CHECK() as well! Maybe it should be renamed to ASSERT()? But that would require flipping all the if() statements around them as well :/ -Toke