Thread (30 messages) 30 messages, 5 authors, 2021-04-12

Re: [PATCH 1/9] mm/page_alloc: Rename alloced to allocated

From: Matthew Wilcox <willy@infradead.org>
Date: 2021-03-25 12:01:32
Also in: linux-mm, linux-nfs, lkml

On Thu, Mar 25, 2021 at 11:42:20AM +0000, Mel Gorman wrote:
Review feedback of the bulk allocator twice found problems with "alloced"
being a counter for pages allocated. The naming was based on the API name
"alloc" and was based on the idea that verbal communication about malloc
tends to use the fake word "malloced" instead of the fake word mallocated.
To be consistent, this preparation patch renames alloced to allocated
in rmqueue_bulk so the bulk allocator and per-cpu allocator use similar
names when the bulk allocator is introduced.

Signed-off-by: Mel Gorman <redacted>
Reviewed-by: Matthew Wilcox (Oracle) <willy@infradead.org>
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help