RE: [EXT] Re: [net-next] net: mvpp2: Add reserved port private flag configuration
From: Stefan Chulski <hidden>
Date: 2021-03-10 16:39:21
Also in:
lkml
-----Original Message----- From: Andrew Lunn <andrew@lunn.ch> Sent: Wednesday, March 10, 2021 5:51 PM To: Stefan Chulski <redacted> Cc: netdev@vger.kernel.org; thomas.petazzoni@bootlin.com; davem@davemloft.net; Nadav Haklai [off-list ref]; Yan Markman [off-list ref]; linux-kernel@vger.kernel.org; kuba@kernel.org; linux@armlinux.org.uk; mw@semihalf.com; rmk+kernel@armlinux.org.uk; atenart@kernel.org; rabeeh@solid-run.com Subject: [EXT] Re: [net-next] net: mvpp2: Add reserved port private flag configuration External Email ----------------------------------------------------------------------quoted
static void mvpp2_ethtool_get_strings(struct net_device *netdev, u32sset,quoted
u8 *data) { struct mvpp2_port *port = netdev_priv(netdev); int i, q; - if (sset != ETH_SS_STATS) - return; + switch (sset) { + case ETH_SS_STATS: + for (i = 0; i < ARRAY_SIZE(mvpp2_ethtool_mib_regs); i++) { + strscpy(data, mvpp2_ethtool_mib_regs[i].string, + ETH_GSTRING_LEN); + data += ETH_GSTRING_LEN; + }Hi Stefan Maybe rename the existing function to mvpp2_ethtool_get_strings_stats() and turn it into a helper. Add a new mvpp2_ethtool_get_strings_priv() helper. And a new mvpp2_ethtool_get_strings() which just calls the two helpers.
OK, I can do this.
Overall the
patch should be smaller and much easier to review.
AndrewMake it patch series? I can split it to 2/3 patches. Thanks, Stefan.