Re: [RFC v2 3/5] arm64: socfpga: rename ARCH_STRATIX10 to ARCH_SOCFPGA64

From
Arnd Bergmann <arnd@arndb.de>
Date
2021-03-10 15:40:50
Also in
linux-arm-kernel, linux-clk, linux-devicetree, linux-edac, linux-fpga, lkml
Reply to
Krzysztof Kozlowski, 2021-03-10
On Wed, Mar 10, 2021 at 4:06 PM Krzysztof Kozlowski
[off-list ref] wrote:
On 10/03/2021 15:45, Tom Rix wrote:
quoted
On 3/10/21 1:45 AM, Lee Jones wrote:
Many other architectures do not have vendor prefix (TEGRA, EXYNOS,
ZYNQMP etc). I would call it the same as in ARMv7 - ARCH_SOCFPGA - but
the Altera EDAC driver depends on these symbols to be different.
Anyway, I don't mind using something else for the name.
I agree the name SOCFPGA is confusing, since it is really a class of
device that is made by multiple manufacturers rather than a brand name,
but renaming that now would be equally confusing. If the Intel folks
could suggest a better name that describes all products in the platform
and is less ambiguous, we could rename it to that. I think ARCH_ALTERA
would make sense, but I don't know if that is a name that is getting
phased out. (We once renamed the Marvell Orion platform to ARCH_MVEBU,
but shortly afterwards, Marvell renamed their embedded business unit (EBU)
and the name has no longer made sense since).

Regardless of what name we end up with, I do think we should have the
same name for 32-bit and 64-bit and instead fix the edac driver to do
runtime detection based on the compatible string.

        Arnd
Thread (18 messages) 18 messages, 4 authors, last reply 2021-03-11
Keyboard shortcuts
hback out one level
jnext message in thread / next series-diff position
kprevious message in thread / previous series-diff position
ldrill in
Escclose help / fold thread tree
?toggle this help