Thread (37 messages) flat view 37 messages, 2 authors, 2021-03-11

Re: [PATCH net-next 03/14] nexthop: Add a dedicated flag for multipath next-hop groups

From: Petr Machata <petrm@nvidia.com>
Date: 2021-03-11 15:40:18

David Ahern [off-list ref] writes:
quoted
diff --git a/include/net/nexthop.h b/include/net/nexthop.h
index 7bc057aee40b..5062c2c08e2b 100644
--- a/include/net/nexthop.h
+++ b/include/net/nexthop.h
@@ -80,6 +80,7 @@ struct nh_grp_entry {
 struct nh_group {
 	struct nh_group		*spare; /* spare group for removals */
 	u16			num_nh;
+	bool			is_multipath;
 	bool			mpath;

It would be good to rename the existing type 'mpath' to something else.
You have 'resilient' as a group type later, so maybe rename this one to
hash or hash_threshold.
All right, I'll send a follow-up with that.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help