Thread (4 messages) flat view 4 messages, 4 authors, 2021-02-14

Re: [PATCH net-next] net: phy: rename PHY_IGNORE_INTERRUPT to PHY_MAC_INTERRUPT

From: Florian Fainelli <f.fainelli@gmail.com>
Date: 2021-02-14 16:51:14
Also in: linux-doc


On 2/14/2021 6:16 AM, Heiner Kallweit wrote:
Some internal PHY's have their events like link change reported by the
MAC interrupt. We have PHY_IGNORE_INTERRUPT to deal with this scenario.
I'm not too happy with this name. We don't ignore interrupts, typically
there is no interrupt exposed at a PHY level. So let's rename it to
PHY_MAC_INTERRUPT. This is in line with phy_mac_interrupt(), which is
called from the MAC interrupt handler to handle PHY events.

Signed-off-by: Heiner Kallweit <hkallweit1@gmail.com>
Acked-by: Florian Fainelli <f.fainelli@gmail.com>

Thanks Heiner!
-- 
Florian
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help