Hello:
This patch was applied to netdev/net.git (refs/heads/master):
On Sat, 13 Feb 2021 18:05:14 +0100 you wrote:
The usage of in_interrupt() in non-core code is phased out. Ideally the
information of the calling context should be passed by the callers or the
functions be split as appropriate.
The attempt to consolidate the code by passing an arguemnt or by
distangling it failed due lack of knowledge about this driver and because
the call chains are hard to follow.
[...]
Here is the summary with links:
- [net-next] net: caif: Use netif_rx_any_context().
https://git.kernel.org/netdev/net/c/d6d8a24023bf
You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html