Thread (21 messages) flat view 21 messages, 5 authors, 2021-01-13

Re: [PATCH net-next 1/5] skbuff: rename fields of struct napi_alloc_cache to be more intuitive

From: Alexander Lobakin <hidden>
Date: 2021-01-11 21:05:03
Also in: lkml

From: Jonathan Lemon <redacted>
Date: Mon, 11 Jan 2021 10:49:45 -0800
On Mon, Jan 11, 2021 at 06:28:21PM +0000, Alexander Lobakin wrote:
quoted
skb_cache and skb_count fields are used to store skbuff_heads queued
for freeing to flush them by bulks, and aren't related to allocation
path. Give them more obvious names to improve code understanding and
allow to expand this struct with more allocation-related elements.
I don't think prefixing these with flush_ is the correct approach;
flush is just an operation on the structure, not a property of the
structure itself.  It especially becomes confusing in the later
patches when the cache is used on the allocation path.
Agree, but didn't come up with anything more fitting. Any suggestions
maybe?
--
Jonathan
Thanks,
Al
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help