Re: [PATCH net-next v2 0/3] nexthop: More fine-grained policies for netlink message validation
From: patchwork-bot+netdevbpf@kernel.org
Date: 2021-01-21 05:18:12
Hello: This series was applied to netdev/net-next.git (refs/heads/master): On Wed, 20 Jan 2021 16:44:09 +0100 you wrote:
There is currently one policy that covers all attributes for next hop object management. Actual validation is then done in code, which makes it unobvious which attributes are acceptable when, and indeed that everything is rejected as necessary. In this series, split rtm_nh_policy to several policies that cover various aspects of the next hop object configuration, and instead of open-coding the validation, defer to nlmsg_parse(). This should make extending the next hop code simpler as well, which will be relevant in near future for resilient hashing implementation. [...]
Here is the summary with links:
- [net-next,v2,1/3] nexthop: Use a dedicated policy for nh_valid_get_del_req()
https://git.kernel.org/netdev/net-next/c/60f5ad5e19c0
- [net-next,v2,2/3] nexthop: Use a dedicated policy for nh_valid_dump_req()
https://git.kernel.org/netdev/net-next/c/44551bff290d
- [net-next,v2,3/3] nexthop: Specialize rtm_nh_policy
https://git.kernel.org/netdev/net-next/c/643d0878e674
You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html