Hello,
In net-sysfs, the xps_cpus_show and xps_rxqs_show functions share the
same logic. To improve readability and maintenance, as discussed
here[1], this series moves their common logic to a new function.
Patches 1/3 and 2/3 are prerequisites for the factorization to happen,
so that patch 3/3 looks better and is easier to review.
Thanks!
Antoine
[1] https://lore.kernel.org/netdev/160875219353.1783433.8066935261216141538@kwain.local/ (local)
Antoine Tenart (3):
net-sysfs: convert xps_cpus_show to bitmap_zalloc
net-sysfs: store the return of get_netdev_queue_index in an unsigned
int
net-sysfs: move the xps cpus/rxqs retrieval in a common function
net/core/net-sysfs.c | 179 +++++++++++++++++++++----------------------
1 file changed, 86 insertions(+), 93 deletions(-)
--
2.29.2