On Tue, Sep 22, 2020 at 12:40 AM Martin KaFai Lau [off-list ref] wrote:
This is a mechanical change to
1. move test_sock_fields.c to prog_tests/sock_fields.c
2. rename progs/test_sock_fields_kern.c to progs/test_sock_fields.c
Minimal change is made to the code itself. Next patch will make
changes to use new ways of writing test, e.g. use skel and global
variables.
Signed-off-by: Martin KaFai Lau <redacted>
---
tools/testing/selftests/bpf/Makefile | 2 +-
.../bpf/{test_sock_fields.c => prog_tests/sock_fields.c} | 6 ++----
.../progs/{test_sock_fields_kern.c => test_sock_fields.c} | 0
Remove it from .gitignore as well?
3 files changed, 3 insertions(+), 5 deletions(-)
rename tools/testing/selftests/bpf/{test_sock_fields.c => prog_tests/sock_fields.c} (99%)
rename tools/testing/selftests/bpf/progs/{test_sock_fields_kern.c => test_sock_fields.c} (100%)
[...]