Thread (27 messages) 27 messages, 4 authors, 2020-09-16

Re: a saner API for allocating DMA addressable pages v2

From: Matthew Wilcox <willy@infradead.org>
Date: 2020-09-14 15:28:37
Also in: alsa-devel, linux-arm-kernel, linux-doc, linux-iommu, linux-media, linux-mips, linux-mm, linux-samsung-soc, linux-scsi, lkml, nouveau

On Mon, Sep 14, 2020 at 04:44:16PM +0200, Christoph Hellwig wrote:
I'm still a little unsure about the API naming, as alloc_pages sort of
implies a struct page return value, but we return a kernel virtual
address.
Erm ... dma_alloc_pages() returns a struct page, so is this sentence
stale?

From patch 14:

+struct page *dma_alloc_pages(struct device *dev, size_t size,
+               dma_addr_t *dma_handle, enum dma_data_direction dir, gfp_t gfp);
The other alternative would be to name the API
dma_alloc_noncoherent, but the whole non-coherent naming seems to put
people off.
You say that like it's a bad thing.  I think the problem is more that
people don't understand what non-coherent means and think they're
supporting it when they're not.

dma_alloc_manual_flushing()?
As a follow up I plan to move the implementation of the
DMA_ATTR_NO_KERNEL_MAPPING flag over to this framework as well, given
that is also is a fundamentally non coherent allocation.  The replacement
for that flag would then return a struct page, as it is allowed to
actually return pages without a kernel mapping as the name suggested
(although most of the time they will actually have a kernel mapping..)
If the page doesn't have a kernel mapping, shouldn't it return a PFN
or a phys_addr?
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help