On Fri, Jul 17, 2020 at 9:40 AM Lorenz Bauer [off-list ref] wrote:
On Fri, 17 Jul 2020 at 11:35, Jakub Sitnicki [off-list ref] wrote:
quoted
Changelog
=========
v4 -> v5:
- Enforce BPF prog return value to be SK_DROP or SK_PASS. (Andrii)
- Simplify prog runners now that only SK_DROP/PASS can be returned.
- Enable bpf_perf_event_output from the start. (Andrii)
- Drop patch
"selftests/bpf: Rename test_sk_lookup_kern.c to test_ref_track_kern.c"
- Remove tests for narrow loads from context at an offset wider in size
than target field, while we are discussing how to fix it:
https://lore.kernel.org/bpf/20200710173123.427983-1-jakub@cloudflare.com/ (local)
- Rebase onto recent bpf-next (bfdfa51702de)
- Other minor changes called out in per-patch changelogs,
see patches: 2, 4, 6, 13-15
- Carried over Andrii's Acks where nothing changed.
Applied. Thanks