Thread (25 messages) flat view 25 messages, 3 authors, 2020-05-26

Re: [net-next RFC PATCH 00/13] net: hsr: Add PRP driver

From: Vinicius Costa Gomes <vinicius.gomes@intel.com>
Date: 2020-05-26 18:09:39
Also in: linux-api, lkml

Hi Vladimir,

Vladimir Oltean [off-list ref] writes:
quoted
I don't really like these prefixes, I am thinking of when support for
IEEE 802.1CB is added, do we rename this to "hsr_prp_frer"?

And it gets even more complicated, and using 802.1CB you can configure
the tagging method and the stream identification function so a system
can interoperate in a HSR or PRP network.
Is it a given that 802.1CB in Linux should be implemented using an hsr
upper device?
What I was trying to express is the idea of using "hsr" as the directory
name/prefix for all the features that deal with frame replication for
reliability, including 802.1CB. At least until we find a better name.
802.1CB is _much_ more flexible than both HSR and PRP. You can have
more than 2 ports, you can have per-stream rules (each stream has its
own sequence number), and those rules can identify the source, the
destination, or both the source and the destination.
Same understanding here.


Cheers,
-- 
Vinicius
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help