What do you think about changing:
"But when nfp_nsp_has_hwinfo_lookup fail, the pointer is not released,.."
to
…
or
"But when nfp_nsp_has_hwinfo_lookup fail,
I became curious about a related wording variant.
But when a call of the function “…” failed,
NSP resource is not cleaned up and unlocked."
I find such information also nicer. (The abbreviation “NSP” might need
another bit of clarification.)
I imagine there might be interests (eventually related to computer science)
to measure the corresponding object sizes because of a missed function call
and offer a more precise information in the commit message
(depending on the willingness to invest efforts in such a data determination).
Will such considerations become relevant for any subsequent
software development approaches?
Regards,
Markus