On Fri, Feb 21, 2020 at 11:28:05AM +0000, Quentin Monnet wrote:
"trace" sounds too generic. If filters are applied again to prog and map
types in the future (as you had in v1), this would catch tracepoint and
raw_tracepoint program types and stack_trace map type. Or if new helpers
with "trace" in their name are added, we skip them too. Can we use something
more specific, probably "trace_printk"?
+1
Thanks for the patch! While I understand you want to keep the changes you
have done to use regex, I do not really think they bring much in this
version of the patch. As we only want to filter out two specific helpers, it
seems to me that it would be much simpler to just compare helper names
instead of introducing regular expressions that are not used otherwise. What
do you think?
+1
I was thinking the same.
Or filter by specific integer id of the helper.