On 23 January 2020 18:25:42 EET, Stephen Hemminger [off-list ref] wrote:
On Thu, 23 Jan 2020 15:28:04 +0200
Nikolay Aleksandrov [off-list ref] wrote:
quoted
return ((p->flags & BR_HAIRPIN_MODE) || skb->dev != p->dev) &&
- br_allowed_egress(vg, skb) && p->state == BR_STATE_FORWARDING &&
+ p->state == BR_STATE_FORWARDING && br_allowed_egress(vg, skb) &&
nbp_switchdev_allowed_egress(p, skb) &&
!br_skb_isolated(p, skb);
}
Maybe break this complex return for readability?
Sure, sounds good, but is not the point of this commit.
I'll prepare a separate cleanup patch for that.
Thanks,
Nik