Nick Desaulniers [off-list ref] writes:
On Thu, Dec 19, 2019 at 5:32 AM Kalle Valo [off-list ref] wrote:
quoted
Nick Desaulniers [off-list ref] writes:
quoted
On Wed, Dec 11, 2019 at 11:23 AM Nathan Chancellor
[off-list ref] wrote:
quoted
wmi_scan_priority and scan_priority have the same values but the wmi one
has WMI prefixed to the names. Since that enum is already being used,
get rid of scan_priority and switch its one use to wmi_scan_priority to
fix this warning.
Also, I don't know if the more concisely named enum is preferable?
I didn't get this comment.
Given two enums with the same values:
enum scan_priority
enum wmi_scan_priority
wouldn't you prefer to type wmi_ a few times less? Doesn't really
matter, but that was the point I was making.
Ah, now I got it :) This enum is part of firmware interface (WMI) so
yes, I prefer to use the wmi_ prefix to make that obvious.
--
https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches