On Thu, 2019-12-05 at 14:38 -0600, Bjorn Helgaas wrote:
The subject contains a couple typos: it's missing "of" and it's
missing the "n" on "down".
Noted >
On Tue, Dec 03, 2019 at 12:47:41PM +0100, Nicolas Saenz Julienne wrote:
quoted
The function now is safe to use while expecting a 64bit value. Use it
where relevant.
Please include the function names ("roundup_pow_of_two()",
"rounddown_pow_of_two()") in the changelog so it is self-contained and
doesn't depend on the subject.
Noted
quoted
Signed-off-by: Nicolas Saenz Julienne <redacted>
With the nits above and below addressed,
Acked-by: Bjorn Helgaas <bhelgaas@google.com> # drivers/pci
Thanks!
quoted
---
drivers/acpi/arm64/iort.c | 2 +-
drivers/net/ethernet/mellanox/mlx4/en_clock.c | 3 ++-
drivers/of/device.c | 3 ++-
drivers/pci/controller/cadence/pcie-cadence-ep.c | 3 ++-
drivers/pci/controller/cadence/pcie-cadence.c | 3 ++-
drivers/pci/controller/pcie-brcmstb.c | 3 ++-
drivers/pci/controller/pcie-rockchip-ep.c | 5 +++--
kernel/dma/direct.c | 2 +-
8 files changed, 15 insertions(+), 9 deletions(-)
--- a/drivers/pci/controller/cadence/pcie-cadence-ep.c
+++ b/drivers/pci/controller/cadence/pcie-cadence-ep.c
@@ -10,6 +10,7 @@
#include <linux/platform_device.h>
#include <linux/pm_runtime.h>
#include <linux/sizes.h>
+#include <linux/log2.h>
#include "pcie-cadence.h"
@@ -65,7 +66,7 @@ static int cdns_pcie_ep_set_bar(struct pci_epc *epc, u8
fn,
* roundup_pow_of_two() returns an unsigned long, which is not suited
* for 64bit values.
*/
Please remove the comment above since it no longer applies.
Noted
[...]
quoted
diff --git a/kernel/dma/direct.c b/kernel/dma/direct.c
index 6af7ae83c4ad..056886c4efec 100644
--- a/kernel/dma/direct.c
+++ b/kernel/dma/direct.c
@@ -53,7 +53,7 @@ u64 dma_direct_get_required_mask(struct device *dev)
{
u64 max_dma = phys_to_dma_direct(dev, (max_pfn - 1) << PAGE_SHIFT);
- return (1ULL << (fls64(max_dma) - 1)) * 2 - 1;
+ return rounddown_pow_of_two(max_dma) * 2 - 1;
Personally I would probably make this one a separate patch since it's
qualitatively different than the others and it would avoid the slight
awkwardness of the non-greppable "roundup/down_pow_of_two()"
construction in the commit subject.
But it's fine either way.
I'll split it into two parts, as RobH made a similar complaint.
Regards,
Nicolas